Welcome, Guest
Username: Password: Remember me
Lab CT Version, news, test results, new features request and suggestions

TOPIC:

CT LAB ver 6.80 3 years 7 months ago #13343

  • Matis A.
  • Matis A.'s Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 779
  • Thank you received: 77
We try hard to solve debugging problems

Try to use and
FpDebugger or
LLDB Debugger

more info
PilotLogic Core Programmer

Please Log in or Create an account to join the conversation.

CT LAB ver 6.80 3 years 7 months ago #13344

  • Rafał
  • Rafał's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 18
  • Thank you received: 0
Hi,

I have same situation with debugger. I try few projects.
Same result: External SIGSEGV,

fpDebugger : External: Access violation

LLDB Debugger: Working, OK.

Please Log in or Create an account to join the conversation.

Last edit: by Rafał.

CT LAB ver 6.80 3 years 7 months ago #13345

  • Matis A.
  • Matis A.'s Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 779
  • Thank you received: 77
Thanks Sir
for the report
PilotLogic Core Programmer

Please Log in or Create an account to join the conversation.

CT LAB ver 6.80 3 years 7 months ago #13346

  • Peter Heckert
  • Peter Heckert's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 62
  • Thank you received: 3
If this is a 32 Bit Problem, then this could help:

If the type of debugging info is set to "default" or "automatic" then the 32 bit FPC compiler produces Stabs debugging info.
(It shouldnt, because Stabs is deprecated but it does)
So the debugging info for the project should be explicitely set to "Dwarf with sets".

This is true for FPC 3.0.4 32 bit and so far I have seen, it is also true for FPC 3.3.1 32 bit.

Please Log in or Create an account to join the conversation.

CT LAB ver 6.80 3 years 7 months ago #13347

  • Matis A.
  • Matis A.'s Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 779
  • Thank you received: 77
Thanks Sir
we must try that
PilotLogic Core Programmer

Please Log in or Create an account to join the conversation.

CT LAB ver 6.80 3 years 7 months ago #13348

  • Rafał
  • Rafał's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 18
  • Thank you received: 0
I tried what Peter Heckert mentioned.

I changed In Project Options -> Debugger -> Debugger Info -> Debugger Format Code from "Automatic" to "Dwarf with sets" and it's working.
There is no errors.

I tried it on few projects.

Please Log in or Create an account to join the conversation.

CT LAB ver 6.80 3 years 7 months ago #13349

  • Matis A.
  • Matis A.'s Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 779
  • Thank you received: 77
The same here
PilotLogic Core Programmer

Please Log in or Create an account to join the conversation.

CT LAB ver 6.80 3 years 7 months ago #13350

  • Sternas Stefanos
  • Sternas Stefanos's Avatar Topic Author
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4426
  • Thank you received: 1073
For the next
LAB CT release we add some new things

-COSMIC 1: Switch "Automatic" Project "Type of Debug info"
to "Dwarf2 with sets" (-gw2 -godwarfsets)
Now all supported by Typhon IDE Debuggers can run without
change working Project Debug Options

-COSMIC 2: Add to Typhon IDE support for DWARF 4 Debugging Format Standard



For testing...
PilotLogic Architect and Core Programmer
Attachments:
The following user(s) said Thank You: xcod, Fernando

Please Log in or Create an account to join the conversation.

Last edit: by Sternas Stefanos.