× CodeTyphon MacOS Development, discussions and problems

Question how to add/remove packages to CT without using CT

  • Inferno
  • Topic Author
  • Offline
  • Junior Member
  • Junior Member
More
4 months 4 days ago #15923 by Inferno
Hi all,
Building CT with some packages causes that CT cannot start. How to remove only the last added broken packages and rebuild CT in such case (without using CT)?

Best regards,
Inferno

 

Please Log in or Create an account to join the conversation.

More
4 months 4 days ago #15924 by Matis A.
The best procedure is
before start your packages tests to backup TyphonIDE executable or simple zip-it
and backup the last good packages configuration.

If your test give you No Start IDE, just restore the last Good TyphonIDE executable
and last good packages configuration

If ALL go wrong "Remove and Build Typhon IDE" or
"Restore IDE Settings" and "Build Small IDE"
 

PilotLogic Core Programmer

Please Log in or Create an account to join the conversation.

  • Inferno
  • Topic Author
  • Offline
  • Junior Member
  • Junior Member
More
4 months 4 days ago #15925 by Inferno
Hi Maits,
Thank you for your advice.

"Remove and Build Typhon IDE" or "Restore IDE Settings" and "Build Small IDE"  - this is exactly what I'm doing but it is time-consuming method...

So there is no way to rebuid CT with CTC by adding/removing some packages to current build configuration? It would be useful feature

I'm asking about that because after upgrade to 7.4.1 on macOS Catalina I cannot bulid CT with Indy package . With v7.3 it works well. Could you please check this?

Best regrds,
Inferno

Please Log in or Create an account to join the conversation.

More
4 months 4 days ago - 4 months 4 days ago #15926 by Matis A.
You can use and CTCenter=>Tools page=>"Typhon BigIDE Packages Setup"

Current LAB CT unreleased
MacOS 11.4
pl_indy 7.5.1


 

download this latest pl_indy from here

It's NOT so simple to support so big Packages/Libraries on MacOS
and we give a lot programming Hours/Days for this.

 

PilotLogic Core Programmer
Attachments:
Last edit: 4 months 4 days ago by Matis A..

Please Log in or Create an account to join the conversation.

  • Inferno
  • Topic Author
  • Offline
  • Junior Member
  • Junior Member
More
4 months 4 days ago #15928 by Inferno
Hi Matis,
The newest Indy v 7.5.1 causes the same issue - CT crashes during start... It looks Catalina nad Big Sur behave different. And I'm not sure if this is component issue itself. I'm not the first one - similar issue was reported here with Synapse: www.pilotlogic.com/sitejoom/index.php/fo...-adding-package.html
The errors are the same in both cases - Resource "windows7_button" not found:

[FORMS.PP] ExceptionOccurred
  Sender=EResNotFound
  Exception=Resource "windows7_button" not found
  Stack trace:
  $00000001055A8A50
  $00000001055A8CA9
  $000000010669FF85
  $00000001066A08C2
  $00000001066A1822
  $00000001066A1FC3
  $00000001054DD6CE
  $00000001054E9D4C
  $00007FFF73A2CCC9
TApplication.HandleException: EResNotFound
Resource "windows7_button" not found
  Stack trace:
  $00000001055A8A50
  $00000001055A8CA9
  $000000010669FF85
  $00000001066A08C2
  $00000001066A1822
  $00000001066A1FC3
  $00000001054DD6CE
  $00000001054E9D4C
  $00007FFF73A2CCC9
Exception at 00000001055A8A50: EResNotFound:
Resource "windows7_button" not found.

Any idea how to fix it?

Best regards,
Inferno

Please Log in or Create an account to join the conversation.

More
4 months 4 days ago #15930 by Matis A.
The only CT version support pl_Indy on MacOS is LAB CT ver 7.50.
We hope to port and pl_Synapse to MacOS.
For your info, LAB CT ver 7.50 support only MacOS 11.x Big Sur.

PilotLogic Core Programmer

Please Log in or Create an account to join the conversation.

More
4 months 3 days ago - 4 months 2 days ago #15931 by Matis A.
Finally we port and pl_Synapse to MacOS.
Now BigIDE has about 1695 components.

Current LAB CT ver 7.50 unreleased
MacOS 11.4
pl_Synapse 7.5.1 and pl_SynapseVS 7.5.1

 

PilotLogic Core Programmer
Attachments:
Last edit: 4 months 2 days ago by Matis A..

Please Log in or Create an account to join the conversation.

  • Inferno
  • Topic Author
  • Offline
  • Junior Member
  • Junior Member
More
3 weeks 1 day ago #16167 by Inferno
Hi Matis,
I finally switched to Big Sur and CT v7.5 where Indy and Synapse componnents work well! Thank you for fixing it!

Best regards,
Inferno

Please Log in or Create an account to join the conversation.

More
3 weeks 1 day ago #16168 by Matis A.
Thanks
have fun

PilotLogic Core Programmer

Please Log in or Create an account to join the conversation.