Forum
× CodeTyphon MS Windows (XP, Vista, Win7, Win8.x and Win10) OS Development, discussions and problems

Question I updated CT 6.7 to 6.8 then got an error when I tried to compile the projects.

  • David Wu
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
6 months 2 weeks ago #13413 by David Wu
Hello fellows,
First of all, Thanks a lot for CT, what a wonderful project! Thanks to all the contributions for this project.
Months before, I download and installed CT 6.7 for windows and cross-compiled some Raspberry pi 3 projects, it worked very well.
days before I updated CT6.7 to CT6.8, something going wrong. whatever I tried compiled any "old project" that made by CT6.7. I always got a message"
Compile package adFCL 6.8.1: Exit code 1, Errors: 1
Fatal: Cannot find system used by fcllaz. Make sure all ppu files of a package are in its output directory. ppu in wrong directory=C:\codetyphon\fpc\fpc64\units\arm-linux\rtl\system.ppu..

then, I clear all and install a brand new CT6.8, the same thing happened.
I guess that is a simple "path" problem, therefore I tried to modify a lot of the project's path options, but the same thing happened.
Does anyone have any suggestions?

Thank you!

Please Log in or Create an account to join the conversation.

More
6 months 2 weeks ago - 6 months 2 weeks ago #13414 by Matis A.
Sir
we want more info for your project, Typhon IDE and your Host PC

PilotLogic Core Programmer
Last edit: 6 months 2 weeks ago by Matis A..

Please Log in or Create an account to join the conversation.

  • David Wu
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
6 months 2 weeks ago #13415 by David Wu
Thank you for your quick reply.
The Host PC is Windows 10 home
The project is a project made by CT6.7, a normal project with forms, because I think maybe the error comes from the project, I make a new project: a form with a button. when I run it in windows 10, everything is ok. when I set the target to arm-linux-Raspbian3, and build it, the error message shows:
Compile package adFCL 6.7.1: Exit code 1, Errors: 1
Fatal: Cannot find system used by fcllaz. Make sure all ppu files of a package are in its output directory. ppu in wrong directory=C:\codetyphon\fpc\fpc64\units\arm-linux\rtl\system.ppu..

just a few minutes ago, I delete the CT6.8, and reinstall CT6.7, Now, what a pity, the project doesn't work anymore. the same thing happened. So, I think I did something short about the cross-compile?

thank you again.

Please Log in or Create an account to join the conversation.

More
6 months 2 weeks ago - 6 months 2 weeks ago #13416 by Matis A.
Sir
the problem is that CT don't support Windows 10 home
the security session it's not the same with Windows 10 Pro or Ent

From the message:Fatal: Cannot find system used by fcllaz. Make sure all ppu files of a package are in its output directory. ppu in wrong directory=C:\codetyphon\fpc\fpc64\units\arm-linux\rtl\system.ppu..

I think arm-linux FPC element NOT build OK

PilotLogic Core Programmer
Last edit: 6 months 2 weeks ago by Matis A..

Please Log in or Create an account to join the conversation.

  • David Wu
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
6 months 2 weeks ago #13418 by David Wu
Thank you, sir, again.
One thing I have to report to you. the CT6.7 works very well on my Windows 10 Home a few days ago.
I have been developing a multi-Len camera core for about a month. It works. I'm sure.
Thank you, let's keep on doing something and find the problem out.
I will try it tonight if I find something, I will post them.

Please Log in or Create an account to join the conversation.

  • David Wu
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
6 months 2 weeks ago #13419 by David Wu
Finally, I make it works.
Frankly, I will say that I do not know why.
I just go through the CrossBulid menu items of the CodeTyphon Center,
That is, after download Cross ToolChain, download OSes of the target.
try:
GDB Builder
GNU make Builder
ToolChain Builder
FPC Cross Elements Builder

for each menu item, I select my target arm-Linux-raspberryPi3

then, start CodeTyphon IDE and try to build the project which had already set the target as arm-Linux-raspberryPi3.

I cannot remember how many times I did, it finally works.

hope this would help someone else.

Thanks to all CT Builders again.

Please Log in or Create an account to join the conversation.

  • David Wu
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
6 months 2 weeks ago #13420 by David Wu
After this project. I will set a CodeTyphon 6.8 up in a Windows 10 Pro or Ent, and try it again. but now I have to move on.

Please Log in or Create an account to join the conversation.