Welcome, Guest
Username: Password: Remember me
CodeTyphon MacOS Development, discussions and problems
  • Page:
  • 1

TOPIC:

application loads behind IDE 7 years 7 months ago #10328

  • Adrian
  • Adrian's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 18
  • Thank you received: 0
Hello everyone,
I am running into a confusing issue when I try to debug with CT.
I am running CT 5.9 QT on Mac OSX El Capitan (the same behaviour was in CT 5.8) and when I launch an app with F9 (or without the debugger as well) the application loads behind the IDE which is confusing. I have to switch to the application to start working with it.
This behaviour does not occur with Lazarus or CT in Windows or Linux.
Is it something mac OS X related? Is there anything I can configure to avoid this annoying behaviour?

Regards

Please Log in or Create an account to join the conversation.

application loads behind IDE 7 years 7 months ago #10329

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4504
  • Thank you received: 1100
Thanks Sir
we will try to fix this
PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

application loads behind IDE 7 years 7 months ago #10333

  • Adrian
  • Adrian's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 18
  • Thank you received: 0
Hello, Just to let you know, I compiled CT 5.8 with carbon (CT 5.9 fails) and the same issue appears.

Regards

Please Log in or Create an account to join the conversation.

application loads behind IDE 7 years 7 months ago #10360

  • Adrian
  • Adrian's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 18
  • Thank you received: 0
Hello Sternas,
Any news about this topic?
Were you able to reproduce it?

Please Log in or Create an account to join the conversation.

application loads behind IDE 7 years 7 months ago #10361

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4504
  • Thank you received: 1100
Sir
I thing we fix this on LAB CT ver 6.00 revision 005910
Please test LAB CT ver 6.00 revision 005910 info
(LAB Development Version (Experimental))

and please report..
PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

application loads behind IDE 7 years 7 months ago #10365

  • Adrian
  • Adrian's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 18
  • Thank you received: 0
Sir,
I've tried to download the development version with no success. The update script freezes suddenly downloading a random file and I could't complete the update.
Is it possible to download the whole zip (as a release version) or the updated zip only?

I'll keep trying to update and I would like to help you to test the fix.

Regards

Please Log in or Create an account to join the conversation.

application loads behind IDE 7 years 7 months ago #10366

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4504
  • Thank you received: 1100
Sir
we can't release LAB CT as a single zip file
PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

application loads behind IDE 7 years 7 months ago #10374

  • Adrian
  • Adrian's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 18
  • Thank you received: 0
OK. I'll keep trying.
Thank you anyway...

Please Log in or Create an account to join the conversation.

application loads behind IDE 7 years 7 months ago #10381

  • Adrian
  • Adrian's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 18
  • Thank you received: 0
Sir,
I could finally download the LAB CT ver 6.0 and the issue remains.
I am running a complete docked IDE (I am attaching the layout xml file) and every time I hit the run button (debugging or not) the app loads behind the IDE.

Regards

Please Log in or Create an account to join the conversation.

application loads behind IDE 7 years 7 months ago #10382

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4504
  • Thank you received: 1100
Thanks Sir
we will try to fix this
PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

application loads behind IDE 7 years 7 months ago #10383

  • Adrian
  • Adrian's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 18
  • Thank you received: 0
Whenever you have something to test, I will download and report.

Thank you

Please Log in or Create an account to join the conversation.

application loads behind IDE 7 years 7 months ago #10384

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4504
  • Thank you received: 1100
Thanks Sir
PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

application loads behind IDE 7 years 6 months ago #10420

  • Adrian
  • Adrian's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 18
  • Thank you received: 0
I've downloaded latest development version and I found out that this issue remains.
I found that if I set the FormStyle property to fsStayOnTop or fsSystemStayOnTop the issue is solved.

Is it possible to set fsStayOnTop to the main form when I am on mac and compiling in debug mode by modifying a template?

Thanks

Please Log in or Create an account to join the conversation.

application loads behind IDE 7 years 6 months ago #10421

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4504
  • Thank you received: 1100
I don't know Sir
Please, give us time to solve and this
PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

application loads behind IDE 7 years 6 months ago #10422

  • Adrian
  • Adrian's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 18
  • Thank you received: 0
Sternas,
I didn't mean to rush you. You make a excelent work.
I was wondering if I can edit something in my instalation to add automatically what I am adding by hand everytime I start a project.
Take your time. I have a workaround now.

REgards

Please Log in or Create an account to join the conversation.

  • Page:
  • 1