Welcome, Guest
Username: Password: Remember me
CodeTyphon Linux OS Development, discussions and problems
  • Page:
  • 1

TOPIC:

Binaries genaration for QT 2 months 16 hours ago #18385

  • Libaud
  • Libaud's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 21
  • Thank you received: 0
Hi,
I think that all known that QT updated with the release 6.6.2, 5.15.3 for his last.
On Linux Mint or Ubuntu, the last releases his 5.15.3 and 6.2.4 if I don't make a mistake.
On Typhon 8.30 it was impossible to correctly build binaries for QT 6 by default. Because integration of Qt isn't correct. But the condition is to have the correct binaries and development source for libqt6pas.
David Bannon took over the project for QT 5 Pascal Object integration and now for QT 6 :
- QT 6 : github.com/davidbannon/libqt6pas ;
- QT 5 : github.com/davidbannon/libqt5pas.
Install the last release package would permit to build binaries on Lazarus, but on Typhon for reason that the integration is not correct.
I have made the corrections, join on attachments.
Best regards.
Frédéric Libaud, Digital Expert
Attachments:

Please Log in or Create an account to join the conversation.

Binaries genaration for QT 2 months 15 hours ago #18387

  • Matis A.
  • Matis A.'s Avatar
  • Away
  • Moderator
  • Moderator
  • Posts: 1076
  • Thank you received: 153
Sir
TyphonIDE "interfaces" are NOT the same with Lazarus "interfaces".

Our QT4, QT5 and QT6 "buildings" working on ALL supported HOST OSes.
We build QT4, QT5 and QT6 interfaces libraries with CTCenter on ALL supported HOST OSes.

So we don't use any of David Bannon GIT source.

 
PilotLogic Core Programmer

Please Log in or Create an account to join the conversation.

Last edit: by Matis A..
  • Page:
  • 1