Forum
× Discussions for CodeTyphon Studio Installation and Setup.

Question Installation on widows 10

  • Angelo Mangiaracina
  • Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
More
1 month 21 hours ago #14284 by Angelo Mangiaracina
Installation on widows 10 was created by Angelo Mangiaracina
Hi, I installed on windows 10 the version 6.90. and compiled both the 32 and 64 Typhon bid ige. now on the 32 bit version I saw that there are only 46 pages of components while in the 64 version there are 144. so in the 32 version lacks many components, for example the jvcl (that I would use). Is it correct or I have done some mistake in the installation? And if it is correct how can I install the lacking components.

Thank you

Please Log in or Create an account to join the conversation.

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Away
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
More
1 month 19 hours ago - 1 month 19 hours ago #14285 by Sternas Stefanos
Replied by Sternas Stefanos on topic Installation on widows 10
ALL correct Sir

To build Typhon64 with 144 packages pages you need about 4 GBytes RAM.

Windows 32 bits support only 2 GBytes RAM
So we select some of CT Packages for Typhon32, in order to use in Building/Rebuilding IDE procedure about 1 GBytes RAM

Always you can add info more packages to Typhon32 IDE
until NO Memory ERROR from Win32 sub system raise.

PS: Why did you install CT 6.90 and not CT 7.00 ?

PilotLogic Architect and Core Programmer
Last edit: 1 month 19 hours ago by Sternas Stefanos.

Please Log in or Create an account to join the conversation.

  • Angelo Mangiaracina
  • Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
More
1 month 2 hours ago #14286 by Angelo Mangiaracina
Replied by Angelo Mangiaracina on topic Installation on widows 10
Thank you for the quick answer.

I installed the 6.9 version just some weeks before the release of version 7, but I plan to upgrade very soon.

Please Log in or Create an account to join the conversation.

  • Angelo Mangiaracina
  • Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
More
4 weeks 2 days ago #14287 by Angelo Mangiaracina
Replied by Angelo Mangiaracina on topic Installation on widows 10
Hi, now I added the pl_jvcl from the list of available package to the install list and saved and rebuilded the ide, but in the list of the install package say that is not installed.

Please Log in or Create an account to join the conversation.

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Away
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
More
4 weeks 2 days ago #14288 by Sternas Stefanos
Replied by Sternas Stefanos on topic Installation on widows 10
Sir
give us more info...
Did you follow the above procedure ?
Attach here a screen of your Typhon32 pkgs list.

Give us "something" to help you :blush:

PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

  • Angelo Mangiaracina
  • Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
More
4 weeks 2 days ago #14290 by Angelo Mangiaracina
Replied by Angelo Mangiaracina on topic Installation on widows 10
Yes I followed it
Attachments:

Please Log in or Create an account to join the conversation.

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Away
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
More
4 weeks 2 days ago #14291 by Sternas Stefanos
Replied by Sternas Stefanos on topic Installation on widows 10
Did you rebuild Typhon IDE ?

PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

  • Angelo Mangiaracina
  • Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
More
4 weeks 2 days ago #14292 by Angelo Mangiaracina
Replied by Angelo Mangiaracina on topic Installation on widows 10
Yes, I clicked on the save and rebuild button

Please Log in or Create an account to join the conversation.

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Away
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
More
4 weeks 1 day ago - 4 weeks 1 day ago #14295 by Sternas Stefanos
Replied by Sternas Stefanos on topic Installation on widows 10
Go to
C:\codetyphon\typhon\
if you find typhon.exe, move it to
C:\codetyphon\typhon\bin32\
folder

PilotLogic Architect and Core Programmer
Last edit: 4 weeks 1 day ago by Sternas Stefanos.

Please Log in or Create an account to join the conversation.

  • Angelo Mangiaracina
  • Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
More
4 weeks 1 day ago #14297 by Angelo Mangiaracina
Replied by Angelo Mangiaracina on topic Installation on widows 10
Solved. Thank you very much

Please Log in or Create an account to join the conversation.