Welcome, Guest
Username: Password: Remember me
General Purpose Components and Libraries, discussions, problems and suggestions
  • Page:
  • 1

TOPIC:

KGrid problem 8 years 5 months ago #8776

  • wolfram
  • wolfram's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 27
  • Thank you received: 1
I have a project with many KGrid controls in many formulars and TPableColntrol windows.
Now the KGrid controls are not longer visible in the designer-window.
What can I do to make the KControl windows visible again in the CodeTyphon designer-window?

May be, I have used/compiled the project with Lazarus some time ago.

In general?
How can I transfer a Lazarus project, that uses the original KControls, to CodeTyphon, which uses its own KControl Lib?

Please Log in or Create an account to join the conversation.

KGrid problem 8 years 5 months ago #8777

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4519
  • Thank you received: 1102
Sir
any error, when open the project with CT?
PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

KGrid problem 8 years 5 months ago #8778

  • wolfram
  • wolfram's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 27
  • Thank you received: 1

Sternas Stefanos wrote: any error, when open the project with CT?


No. I can open and compile.
If I run the application, then an exception occurs in the first line of TKCustomGrid.SetCells during the first call of TKCustomGrid.SetCells().
System is Win7 64 with CodeTypon 5.6 32bit.

If I create a new project and use a KGrid control then this works.

Please Log in or Create an account to join the conversation.

KGrid problem 8 years 5 months ago #8779

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4519
  • Thank you received: 1102
Did you use the same KGrid version
please, give us more information or data,
with the problem only, we can't help you... :blush:
PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

KGrid problem 8 years 5 months ago #8784

  • wolfram
  • wolfram's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 27
  • Thank you received: 1

Sternas Stefanos wrote: Did you use the same KGrid version
please, give us more information or data,
with the problem only, we can't help you... :blush:


I do not know exactly what happend with the project before.
Me be I have tried to compil it with Lazarus und have tried to register Typhon pl_KControls in Lazarus.

The fact is, I compiled this project many times successfuyl with all Typhon version during the last 3 Years.
An I did not change the source code.

Now I compiled the project with the new Typhon 5.6 verion and found, that only the source tab appears.
Then I opend with menu "Project" - "Form" each form in the project and now the tab "Design" appears for each form.
But the KGrid controls ar not longer visible in the Designer an all KGrid controls are not longer listed in the Property window!

The question now is: Can I regenerate the formular data?
Or what can I do?
Or ist it not possible to regenerate the formular data?

May be I can find a backup of the project somewhere....

Best Regards

Please Log in or Create an account to join the conversation.

KGrid problem 8 years 5 months ago #8785

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4519
  • Thank you received: 1102
Try to find an old version, is the best solution
PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

  • Page:
  • 1