Welcome, Guest
Username: Password: Remember me
General Purpose Components and Libraries, discussions, problems and suggestions
  • Page:
  • 1

TOPIC:

StringGrid and the LoadFromCSVFile problem 8 years 7 months ago #8534

  • swallow95
  • swallow95's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 9
  • Thank you received: 0
I like to use the StringGrid1.LoadFromCSVFile() function.
It works but also randomly ​set to a last line of strange characters
Image...


In the CSV file normal view are not these characters. I checked csv files in hex viewer and are not these characters.

(I did a test, I wrote a Delphi code in a delphi IDE with unique function and stringgrid, and are not these characters.
I use the same csv files.)

What's wrong in the LoadFromCSVFile() function?

this video presents the phenomenon


I tested it with CT ver 5.50 and CT LAB ver 5.60

This an attachment includes example project and my csv files with UCS-2 Little Endian encode

File Attachment:

File Name: StrGridCSV...Load.zip
File Size:486 KB



Please help me?

Please Log in or Create an account to join the conversation.

Last edit: by swallow95.

StringGrid and the LoadFromCSVFile problem 8 years 7 months ago #8558

  • swallow95
  • swallow95's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 9
  • Thank you received: 0
I wrote a bug report on the lazarus bugtracker
I tested this phenomenon on the Lazarus svn 50317 and the same problem is there too

Please Log in or Create an account to join the conversation.

Last edit: by swallow95.
  • Page:
  • 1