Welcome, Guest
Username: Password: Remember me
General discussions, feature requests for CodeTyphon Project and discussions that don't fit in any of the other specific CodeTyphon forum categories.
  • Page:
  • 1

TOPIC:

Upgrading to CT 6.50 issue 5 years 10 months ago #11786

  • patrick
  • patrick's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 24
  • Thank you received: 0
Hi guys,

I just updated my CT system from version 6.40 to 6.50 and got some issue with my reports (Tfr Reports). Now some fields do not render the accentuated strings. It appears like Unicode is not implemented in some cases. It is rather weird effect as some reports still show the accentuated letters.

Maybe some advice

Thanks in advance

Biobytes

Please Log in or Create an account to join the conversation.

Upgrading to CT 6.50 issue 5 years 10 months ago #11787

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4518
  • Thank you received: 1102
Thanks Sir
Always you can use pl_FortesReport package from CT 6.40

Please, can you attach a test project to find the problem ?
PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

Upgrading to CT 6.50 issue 5 years 10 months ago #11788

  • patrick
  • patrick's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 24
  • Thank you received: 0
Thank for your reply Sternas,

I tried to move to Fortes report package but it is not fine for me as In cannot get it in French.

I try to prepare a test project to post it asap

Thanks
Biobytes

Please Log in or Create an account to join the conversation.

Last edit: by patrick.

Upgrading to CT 6.50 issue 5 years 10 months ago #11789

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4518
  • Thank you received: 1102
Ok
PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

Upgrading to CT 6.50 issue 5 years 10 months ago #11812

  • patrick
  • patrick's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 24
  • Thank you received: 0
Hi,

After several tries, I found why some fields in my lzReports did not render accentuated characters. The problem comes from the "longtext" fields defined in the MySQL database. After changing the "longtext" format to "VarChar(6000)", the problem disappeared and the reports displayed correctly the accentuated strings. This is really a bug in TfrReport package.

I noted also that Image field appearing in report preview is not printed when sending the report to the printer (!?)

Maybe some comments

Biobytes

Please Log in or Create an account to join the conversation.

Upgrading to CT 6.50 issue 5 years 10 months ago #11813

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4518
  • Thank you received: 1102
I think we solve the problem with images in pl_FortesReport ver 6.5
PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

Upgrading to CT 6.50 issue 5 years 10 months ago #11838

  • patrick
  • patrick's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 24
  • Thank you received: 0
Hi,

The issue with the emmbedded image in fortes report still persists. The problem appears when the image object is inserted in a header band.

Regards
Biobytes

Please Log in or Create an account to join the conversation.

Upgrading to CT 6.50 issue 5 years 10 months ago #11839

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4518
  • Thank you received: 1102
Thanks Sir
we will try to fix and this
PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

  • Page:
  • 1