Welcome, Guest
Username: Password: Remember me
CodeTyphon Cross-Build Development, discussions and problems
  • Page:
  • 1

TOPIC:

WIN-CE CT 6.2 error 6 years 5 months ago #10986

  • Segami Steve
  • Segami Steve's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 16
  • Thank you received: 0
Hi,

1° We have several projects developped with CT 6.0

2° We convert projects to be compatible with CT 6.2

3° It is impossible to compile for WinCE / arm / processor: default / LCL wince, we have an error (see below the messages):

Compile checks - Conseils : 12
Note: package adFCL 6.2.1: l'option "-g" est passée deux fois au compilateur avec des valeurs différentes
Note: package adFCL 6.2.1: l'option "-gl" est passée deux fois au compilateur avec des valeurs différentes
Note: package bs_Utils 6.2.2: l'option "-g" est passée deux fois au compilateur avec des valeurs différentes
Note: package bs_Utils 6.2.2: l'option "-gl" est passée deux fois au compilateur avec des valeurs différentes
Note: package adLCLBase 6.2.1: l'option "-g" est passée deux fois au compilateur avec des valeurs différentes
Note: package adLCLBase 6.2.1: l'option "-gl" est passée deux fois au compilateur avec des valeurs différentes
Note: package adLCL 6.2.1: l'option "-g" est passée deux fois au compilateur avec des valeurs différentes
Note: package adLCL 6.2.1: l'option "-gl" est passée deux fois au compilateur avec des valeurs différentes
Note: package bs_Controls 6.2.1: l'option "-g" est passée deux fois au compilateur avec des valeurs différentes
Note: package bs_Controls 6.2.1: l'option "-gl" est passée deux fois au compilateur avec des valeurs différentes
Note: package bs_IDEIntf 6.2.1: l'option "-g" est passée deux fois au compilateur avec des valeurs différentes
Note: package bs_IDEIntf 6.2.1: l'option "-gl" est passée deux fois au compilateur avec des valeurs différentes
Compiler le paquet adFCL 6.2.1 : Code de sortie 1 - Erreurs : 1
Error: ppcarm.exe can't be executed, error message: Failed to execute ""ppcarm.exe" -B -Twince -MObjFPC -Scghi -O1 -g -gl -l -vewnhibq -FuC:\codetyphon\typhon\packager\registration\ -FUC:\codetyphon\typhon\packager\units\arm-wince\ -g- fcllaz.pas

Where is the problem?

Thank for your help

Best Regard

Please Log in or Create an account to join the conversation.

WIN-CE CT 6.2 error 6 years 5 months ago #10988

  • Segami Steve
  • Segami Steve's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 16
  • Thank you received: 0
We have build again the "FPC32 build cross element arm-wince" in CodeTyphon Center ("Cross-Build->FreePascal 32bits->FPC32 build cross element arm-wince") and it is possible to compile but when we run the application on a wince device, we have a problem with command "ShowMessage('....')...

On the "ShowMessage", the compiled executable stay in a loop and open indefinitely popups with the desired message!

Same problem when we use a splashscreen at the start of the application... Compiled executable cannot manage changes of windows

We must reset the device to close the executable...

Please Log in or Create an account to join the conversation.

Last edit: by Segami Steve.

WIN-CE CT 6.2 error 6 years 5 months ago #10990

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4501
  • Thank you received: 1096
Sorry Sir
we don't have any wince device here to test CT :blush:
Support for winCE OS it's not possible... :blush:
PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

Last edit: by Sternas Stefanos.

WIN-CE CT 6.2 error 6 years 5 months ago #10994

  • Segami Steve
  • Segami Steve's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 16
  • Thank you received: 0
Hi,

A wince device is not necessary to test the problem of CT6.20. The problem can be tested with Microsoft Device Emulator 3.0 as described on your page:

www.pilotlogic.com/sitejoom/index.php/93...uild-for-wince-6-5-3

File Attachment:

File Name: TestWinMgt...ince.zip
File Size:1,477 KB

In attachment, I add a simple project with an .exe cross-compiled with CT6.20 (when you press on the button, a code line "ShowMessage('Hello word!');" must display a popup). When you run it on Microsoft Device Emulator 3.0, the problem appears!

This problem doesn't exist with CT6.15

Best Regards

Steve

Please Log in or Create an account to join the conversation.

  • Page:
  • 1