× CodeTyphon Cross-Build Development, discussions and problems

Question /system/bin/linker cannot link executable has text relocations Aborted!

  • mashomee
  • Topic Author
  • Offline
  • New Member
  • New Member
More
4 years 5 months ago - 4 years 5 months ago #10859 by mashomee
Hi there!

I've succeded cross compiling for andriod platform, according the ct wiki and some google search results.

but when i ran it in the adb shell, it failed with some strange message. I've googled, but with no solution, need some help, Thanks!

Here is what i do.
1. create a new "Application" project through project wizard.
2. crossing compiling the project for andriod according ct wiki.
3. use adb copy the compiled project1 file to my phone.
4. open the adb shell and su to root
5. add executable permisson and run it
6. it failed running showing some linker error message
7. but if i compiled the "Simple Program", and run it in the same way, it succeded without an error
8. Here is the screenshot(attachment1) .
9. some information.
host os:win7 64
ct version:Tython64 big ide 6100 stable release
phone:phoenix aosp extended 7.1.2 andriod on oneplus 3T


I've googled, but without any useful worked solution.

PS. how to add some linker option like "-z text" or "-z textoff" in the "project option" window as shown in attachment2 .
PS1. perhapes there's a bug in ct 6100: when i open example browser window through project window, the project window doesn't hidden, so i can't open any example project.:(
as shown in attachment3 screenshot .
Last edit: 4 years 5 months ago by mashomee. Reason: attachment not shown right

Please Log in or Create an account to join the conversation.