Welcome, Guest
Username: Password: Remember me
Lab CT Version, news, test results, new features request and suggestions

TOPIC:

CT LAB ver 5.10 - Ctrl-Space problem 8 years 2 months ago #6050

  • FredyCC
  • FredyCC's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Database/Developer
  • Posts: 60
  • Thank you received: 10
Thank you very much Sternas, works perfect on windows, but I have problems on Mint, once completed upgrade and install when trying to execute an action in the CT Center, do not run anything, it's like you will not find any script, this happens in most menu options.

I've already tried running setup.sh, it runs successfully but the problem persists.

Thanks in advance

Please Log in or Create an account to join the conversation.

CT LAB ver 5.10 - Ctrl-Space problem 8 years 2 months ago #6051

  • FredyCC
  • FredyCC's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Database/Developer
  • Posts: 60
  • Thank you received: 10
I'm sorry, just execute CodeTyphon with su and no problem.

regards

Please Log in or Create an account to join the conversation.

CT LAB ver 5.10 - Ctrl-Space problem 8 years 2 months ago #6052

  • Sternas Stefanos
  • Sternas Stefanos's Avatar Topic Author
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4426
  • Thank you received: 1073
Sir, did you add to sudoers file the line

username ALL=(ALL) NOPASSWD: ALL ?

we have full instructions here
PilotLogic Architect and Core Programmer
The following user(s) said Thank You: FredyCC

Please Log in or Create an account to join the conversation.

CT LAB ver 5.10 - Ctrl-Space problem 8 years 2 months ago #6058

  • Dinko
  • Dinko's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 91
  • Thank you received: 5
I tried what you suggested and I got same behavior as it was with old pl_indy package.
I download the package and unistall from Typhon and then install.

Regards, Dinko

Please Log in or Create an account to join the conversation.

CT LAB ver 5.10 - Ctrl-Space problem 8 years 2 months ago #6059

  • Dinko
  • Dinko's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 91
  • Thank you received: 5
Now I tried with ct500 pl_indy package and everything is OK.
Something is wrong will whole pl_indy ct510 package.

Please Log in or Create an account to join the conversation.

CT LAB ver 5.10 - Ctrl-Space problem 8 years 2 months ago #6062

  • Sternas Stefanos
  • Sternas Stefanos's Avatar Topic Author
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4426
  • Thank you received: 1073
Sir,
I think this new version of pl_Indy with
flat directory, must solve your problem,
if not please post the "options->path" values of your project
PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

CT LAB ver 5.10 - Ctrl-Space problem 8 years 2 months ago #6063

  • Dinko
  • Dinko's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 91
  • Thank you received: 5
Yes. Now it is OK.
Thank you very very much.

BTW.
As much I can tell, CT 5.10 debugger is OK.

Please Log in or Create an account to join the conversation.

CT LAB ver 5.10 - Ctrl-Space problem 8 years 2 months ago #6064

  • XANDR
  • XANDR's Avatar
  • Visitor
  • Visitor
LAB 5.10 The one of previous problem is not solved. If select arm-linux target and select CPU for example ARMv7 and build app - then link Error: Error while assembling exitcode 1. If select the "default" value - will build ok.

Please Log in or Create an account to join the conversation.

Last edit: by XANDR.

CT LAB ver 5.10 - Ctrl-Space problem 8 years 2 months ago #6067

  • Sternas Stefanos
  • Sternas Stefanos's Avatar Topic Author
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4426
  • Thank you received: 1073
Sir
I think, this is FreePascal problem
PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

CT LAB ver 5.10 - Ctrl-Space problem 8 years 2 months ago #6075

  • XANDR
  • XANDR's Avatar
  • Visitor
  • Visitor
Since Ver 4.9 I could not turn off hints (-hv). Is this FreePascal problem too ?

Please Log in or Create an account to join the conversation.

CT LAB ver 5.10 - Ctrl-Space problem 8 years 2 months ago #6089

  • Sternas Stefanos
  • Sternas Stefanos's Avatar Topic Author
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4426
  • Thank you received: 1073
09-10-2014: We release Lab CT 5.10 Revision: 005021
changes log at topic first page

Please test and report here
PilotLogic Architect and Core Programmer
The following user(s) said Thank You: FredyCC

Please Log in or Create an account to join the conversation.

Last edit: by Sternas Stefanos.

CT LAB ver 5.10 - Ctrl-Space problem 8 years 1 month ago #6094

  • gulyone
  • gulyone's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 99
  • Thank you received: 4
still very strange assembler box behavior on win32/64 (interrogation marks and then it writes code lines from your source instead of disassem opcodes if you press step into) but ok no more division by zero crash. thank you very much for that! I know you are doing huge great work on other stuffs... I hope a normal dissassembly display is going to be back in a while... thanks again! congratulations for the embeded designer!

Please Log in or Create an account to join the conversation.

Last edit: by gulyone.

CT LAB ver 5.10 - Ctrl-Space problem 8 years 1 month ago #6095

  • Sternas Stefanos
  • Sternas Stefanos's Avatar Topic Author
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4426
  • Thank you received: 1073
Thanks Sir
PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

CT LAB ver 5.10 8 years 1 month ago #6096

  • Vadim
  • Vadim's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 4
  • Thank you received: 0
please update pl_FPSpreadsheet because a lot of updates from SVN

Please Log in or Create an account to join the conversation.

CT LAB ver 5.10 8 years 1 month ago #6097

  • Sternas Stefanos
  • Sternas Stefanos's Avatar Topic Author
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4426
  • Thank you received: 1073
Thanks Sir, we will do
PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

CT LAB ver 5.10 8 years 1 month ago #6098

  • gulyone
  • gulyone's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 99
  • Thank you received: 4
Just noticed an other issue Sternas = Project >> Options >> other >>> button "all options" displayed choices of all FPC options in other typhon versions... An EMPTY box pops up for now. (win32/64)

Please Log in or Create an account to join the conversation.

Last edit: by gulyone.

CT LAB ver 5.10 8 years 1 month ago #6099

  • Sternas Stefanos
  • Sternas Stefanos's Avatar Topic Author
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4426
  • Thank you received: 1073
Thanks Sir
we will check and fix this
PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

CT LAB ver 5.10 8 years 1 month ago #6105

  • XANDR
  • XANDR's Avatar
  • Visitor
  • Visitor
Last LAB 5.10 version. Target arm-linux.The bug: (.text+0x88): undefined reference to `_fini', (.text+0x90): undefined reference to `_init' (incorrect source file cprt0.as (c:\codetyphon\fpcsrc\rtl\linux\arm\)) is still not fixed.

Please Log in or Create an account to join the conversation.

CT LAB ver 5.10 8 years 1 month ago #6106

  • Sternas Stefanos
  • Sternas Stefanos's Avatar Topic Author
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
  • Posts: 4426
  • Thank you received: 1073
Sir
this is FreePascal "area 51"
please send the problem to FPC bugtracker
PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

CT LAB ver 5.10 8 years 1 month ago #6107

  • XANDR
  • XANDR's Avatar
  • Visitor
  • Visitor
They says that it is was fixed: bugs.freepascal.org/view.php?id=24056

Please Log in or Create an account to join the conversation.