Forum
× Ultra Web Server discussions and problems.

Question [BUG] Changing Apache Server Port

  • Pancho
  • Pancho's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 months 6 days ago #13161 by Pancho
[BUG] Changing Apache Server Port was created by Pancho
There seems to be a problem with changing the Apache Server Port:

1. I changed my Apache Server Port to 4001. No problem.
2. When I changed it back to 80, I got the dialog box confirming the change.
3. When I now try and open the site, the url reverts to the localhost:4001. Unable to Connect

It's seems like somewhere the ${AP_PORT} is not being refreshed to the new value.

Thanks!

Please Log in or Create an account to join the conversation.

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
More
3 months 5 days ago - 3 months 5 days ago #13164 by Sternas Stefanos
Replied by Sternas Stefanos on topic [BUG] Changing Apache Server Port
Thanks Sir
we will test and Report/Fix

Your OS ?

PilotLogic Architect and Core Programmer
Last edit: 3 months 5 days ago by Sternas Stefanos.

Please Log in or Create an account to join the conversation.

  • Pancho
  • Pancho's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 months 4 days ago #13173 by Pancho
Replied by Pancho on topic [BUG] Changing Apache Server Port
Windows 7

Latest version of UniServer has the same issue.

Thanks!

Please Log in or Create an account to join the conversation.

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
More
3 months 4 days ago #13180 by Sternas Stefanos
Replied by Sternas Stefanos on topic [BUG] Changing Apache Server Port
Thanks Sir
NOT UniServer but Ultra Web Server

PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

  • Pancho
  • Pancho's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
2 months 3 weeks ago - 2 months 3 weeks ago #13197 by Pancho
Replied by Pancho on topic [BUG] Changing Apache Server Port
:) I know UWS is not UniServer. Just wanted to let you know that it's an old issue in that program too. Thanks!
Last edit: 2 months 3 weeks ago by Pancho.

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago - 2 months 3 weeks ago #13198 by Matis A.
Replied by Matis A. on topic [BUG] Changing Apache Server Port
Sir
UWS don't has this problem

PilotLogic Core Programmer
Last edit: 2 months 3 weeks ago by Matis A..

Please Log in or Create an account to join the conversation.

  • Pancho
  • Pancho's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
2 months 3 weeks ago #13210 by Pancho
Replied by Pancho on topic [BUG] Changing Apache Server Port
[SOLVED]. Turns out to be a WordPress issue. When you change the original port that was used when WP was installed it keeps on redirecting to the old port. Both the siteurl and home records use the old port. You can use phpMyAdmin and edit the wp_options table to update the port.

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago #13211 by Matis A.
Replied by Matis A. on topic [BUG] Changing Apache Server Port
Thanks Sir

PilotLogic Core Programmer

Please Log in or Create an account to join the conversation.