Forum
× Ultra Web Server Elements discussions and problems.

Question PHP updates

  • Henry
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 months 1 week ago #13023 by Henry
PHP updates was created by Henry
Hello.
Please create .7z modules for the latest PHP releases:

php 5.6.40
php 7.1.26
php 7.2.14
php 7.3.1

Please Log in or Create an account to join the conversation.

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
More
3 months 1 week ago #13024 by Sternas Stefanos
Replied by Sternas Stefanos on topic PHP updates
Thanks Sir
we start now, please give us time

PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
More
3 months 1 week ago - 3 months 1 week ago #13025 by Sternas Stefanos
Replied by Sternas Stefanos on topic PHP updates
We
upload to our servers new UWS Elements:

-mus001w64_PHP_5_6_40_00.7z
-mus001w64_PHP_7_1_26_00.7z
-mus001w64_PHP_7_2_14_00.7z
-mus001w64_PHP_7_3_1_00.7z
-mus001w64_StrawberryPERL_5_28_1_1.7z

Relplace with Fixed version Element:

-mus001w64_MySQL_8_0_13_00.7z

Have fun....

PilotLogic Architect and Core Programmer
Last edit: 3 months 1 week ago by Sternas Stefanos.
The following user(s) said Thank You: JoeDer

Please Log in or Create an account to join the conversation.

More
3 months 6 days ago #13031 by Edwin
Replied by Edwin on topic PHP updates
Thanks for UWS, i love it!. However i couldn't find the mentioned elements in the last post at least in the UWS elements download page, could you give me a glue about where to find them please.
thanks in advance.

Please Log in or Create an account to join the conversation.

  • Matis A.
  • Matis A.'s Avatar
  • Away
  • Moderator
  • Moderator
More
3 months 6 days ago - 3 months 6 days ago #13032 by Matis A.
Replied by Matis A. on topic PHP updates
Thanks Sir

Close all Servers

1) Open "Elements Manager"



2)Hit "Get elements list from Web"



3) Selects the Elements you want from right list and hit "Download and Install"



UWS will download and install selected elements


We make same changes for the next UWS ver 1.20

PilotLogic Core Programmer
Attachments:
Last edit: 3 months 6 days ago by Matis A..
The following user(s) said Thank You: JoeDer

Please Log in or Create an account to join the conversation.

More
3 months 6 days ago #13033 by Edwin
Replied by Edwin on topic PHP updates
That is awesome, thank you for all your help.

Please Log in or Create an account to join the conversation.

More
3 months 6 days ago #13034 by Edwin
Replied by Edwin on topic PHP updates
by the way is possible to have several local versions of same component?, per example php 5.5, 5.6 and 7.1 or is mandatory each time you select a newer or older component this replaces the local existing one, i saw an option to chose the php version but it only show me none and the existing local version, despite i tried to select and install several versions of that component.
thanks

Please Log in or Create an account to join the conversation.

  • Matis A.
  • Matis A.'s Avatar
  • Away
  • Moderator
  • Moderator
More
3 months 6 days ago #13035 by Matis A.
Replied by Matis A. on topic PHP updates
For PHP, MySQL and MariaDB
you can have many "Primary or Main" versions
PHP 5.6, 5.7 or
MariaDB 10.1, 10.2, 10.3

You can't have, for sample MariaDB 10.3.11 and 10.3.12 version in the same UWS directory.
10.3.12 version is bug fix of 10.3.11.

We must set a limit to UWS multi-elements layer

PilotLogic Core Programmer

Please Log in or Create an account to join the conversation.

More
3 months 2 days ago #13040 by JoeDer
Replied by JoeDer on topic PHP updates
Is it possible to add previews unsupported versions like 5.4 and 5.3 for old scripts?

Please Log in or Create an account to join the conversation.

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
More
3 months 2 days ago - 3 months 2 days ago #13041 by Sternas Stefanos
Replied by Sternas Stefanos on topic PHP updates
Sorry Sir
but are to old versions

PilotLogic Architect and Core Programmer
Last edit: 3 months 2 days ago by Sternas Stefanos.

Please Log in or Create an account to join the conversation.

More
3 months 2 days ago #13042 by JoeDer
Replied by JoeDer on topic PHP updates
There are old scripts need upgrade and it's dangerous to setup a live environment in order to upgrade them, local env is the best way to test and do all the necessary work with them, so if could apply these 2 older versions it would be great. BTW, you have done a really awesome work!

Please Log in or Create an account to join the conversation.

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
More
3 months 2 days ago #13045 by Sternas Stefanos
Replied by Sternas Stefanos on topic PHP updates
Sorry Sir
but we will NOT support so old PHP versions

PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago #13067 by Edwin
Replied by Edwin on topic PHP updates
What about php v7.1.10 could be possible to add it to the available packages?
thanks

Please Log in or Create an account to join the conversation.

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
More
2 months 3 weeks ago #13068 by Sternas Stefanos
Replied by Sternas Stefanos on topic PHP updates
Sir
If your PHP script work with PHP 7.1.24 will work and with PHP 7.1.10

PHP 7.1.24 , PHP 7.1.25 , PHP 7.1. 26 versions are the same with PHP 7.1.10
but with Bug fixes

Our Lab now has a lot of daily tasks.
Every day 1-2 programmers from our Lab, work only with UWS new elements.
We release UWS before 1 month and we have already in our server 38 new elements. :unsure:

Did you try PHP 7.1.24 or PHP 7.1.25 or PHP 7.1. 26 ?

PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago #13071 by Edwin
Replied by Edwin on topic PHP updates
Dear sir, i understand you perfectly. I already tested the 1,24, 1.25 and so on. In fact my issue is related to some of my Laravel scripts doesn't work in php versions below 7.1.0 and above 7.1.10
thanks anyway for your answer and for this project.

Please Log in or Create an account to join the conversation.

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Offline
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
More
2 months 3 weeks ago #13074 by Sternas Stefanos
Replied by Sternas Stefanos on topic PHP updates
OK
Sir we uploaded
mus001w64_PHP_7_1_10_00.7z

have fun...

PilotLogic Architect and Core Programmer

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago #13077 by Edwin
Replied by Edwin on topic PHP updates
Thank you very much i really apreciate your help and effort.

Please Log in or Create an account to join the conversation.