Forum

× CodeTyphon MacOS Development, discussions and problems

Question No Menus on Typhon32/Typhon64 Cocoa builds (CT 6.3 / CT 6.4 beta)

  • Manos S. Pappas
  • Manos S. Pappas's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
More
10 months 3 weeks ago - 10 months 3 weeks ago #11213 by Manos S. Pappas
Hello,

On my OSX system (High Sierra 10.13.2), both Typhon32 and Typhon64 IDEs appear without any menus on the system menu bar (other than the Apple and typhon menu which does not even open) when they are compiled against Cocoa framework.
Tried clean install of CT6.3 distribution (removed all user settings also), updated all system libraries without issues, compiled, same thing.
Upgrading to CT6.4 beta (the 'lab' version), removed all setting files, updated all system libraries (again) without issues, compiled, same thing.

Is there something I am doing wrong?
Thank you very much in advance.

Best Regards,
Manos S. Pappas
Attachments:
Last edit: 10 months 3 weeks ago by Manos S. Pappas.

Please Log in or Create an account to join the conversation.

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Away
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
More
10 months 3 weeks ago - 10 months 3 weeks ago #11214 by Sternas Stefanos
Thanks Sir
on MacOS Cocoa platform need work...
For our test we use High Sierra 10.13.2

For MacOS my suggestion is to use
Lab CT 6.40, Typhon64 with QT4 as IDE HOST platform (64 bits)

And QT5 (64 bits) it's OK, but my suggestion is QT4 until we fix Cocoa problems
GTK2 (64 bits) has a problem with font size
Carbon (32 bits) work's OK, like QT4 and QT5

CodeTyphon Architect and Programmer
Last edit: 10 months 3 weeks ago by Sternas Stefanos.
The following user(s) said Thank You: Manos S. Pappas

Please Log in or Create an account to join the conversation.