Forum
× CodeTyphon Linux OS Development, discussions and problems

Question CT 6.3 on openSUSE, cross compiling Raspberry3 error

  • Diogo
  • Diogo's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 months 3 days ago #11212 by Diogo
Diogo created the topic: CT 6.3 on openSUSE, cross compiling Raspberry3 error
I have installed CodeTyphon. 6.3 on openSUSE ( www.pilotlogic.com/sitejoom/index.php/wiki?id=559 )
After that i have installed Cross-Build for Raspberry3 ( www.pilotlogic.com/sitejoom/index.php/wiki?id=499 )
The CT compile for Linux32 and Linux64, but arm-linux-Raspberry3 show error.

The cross compilation for Raspberry works under DeepIn and Windows 7

Compile Project, Mode: Raspberry, CPU: arm, Target: project1: Exit code 256, Errors: 1
/usr/local/codetyphon/fpc/fpc64/bin/x86_64-linux/arm-linux-ld: skipping incompatible /usr/lib/crti.o when searching for /usr/lib/crti.o
/usr/local/codetyphon/fpc/fpc64/bin/x86_64-linux/arm-linux-ld: cannot find /usr/lib/crti.o
/usr/local/codetyphon/fpc/fpc64/bin/x86_64-linux/arm-linux-ld: skipping incompatible /usr/lib//libdl.so when searching for -ldl
/usr/local/codetyphon/fpc/fpc64/bin/x86_64-linux/arm-linux-ld: skipping incompatible /usr/lib//libpthread.so when searching for -lpthread
/usr/local/codetyphon/fpc/fpc64/bin/x86_64-linux/arm-linux-ld: skipping incompatible /usr/lib//libgdk-x11-2.0.so when searching for -lgdk-x11-2.0
/usr/local/codetyphon/fpc/fpc64/bin/x86_64-linux/arm-linux-ld: skipping incompatible /usr/lib//libX11.so when searching for -lX11
/usr/local/codetyphon/fpc/fpc64/bin/x86_64-linux/arm-linux-ld: skipping incompatible /usr/lib//libgdk_pixbuf-2.0.so when searching for -lgdk_pixbuf-2.0
/usr/local/codetyphon/fpc/fpc64/bin/x86_64-linux/arm-linux-ld: skipping incompatible /usr/lib//libgtk-x11-2.0.so when searching for -lgtk-x11-2.0
/usr/local/codetyphon/fpc/fpc64/bin/x86_64-linux/arm-linux-ld: skipping incompatible /usr/lib//libgobject-2.0.so when searching for -lgobject-2.0
/usr/local/codetyphon/fpc/fpc64/bin/x86_64-linux/arm-linux-ld: skipping incompatible /usr/lib//libglib-2.0.so when searching for -lglib-2.0
/usr/local/codetyphon/fpc/fpc64/bin/x86_64-linux/arm-linux-ld: skipping incompatible /usr/lib//libgthread-2.0.so when searching for -lgthread-2.0
/usr/local/codetyphon/fpc/fpc64/bin/x86_64-linux/arm-linux-ld: skipping incompatible /usr/lib//libgmodule-2.0.so when searching for -lgmodule-2.0
/usr/local/codetyphon/fpc/fpc64/bin/x86_64-linux/arm-linux-ld: skipping incompatible /usr/lib//libpango-1.0.so when searching for -lpango-1.0
/usr/local/codetyphon/fpc/fpc64/bin/x86_64-linux/arm-linux-ld: skipping incompatible /usr/lib//libcairo.so when searching for -lcairo
/usr/local/codetyphon/fpc/fpc64/bin/x86_64-linux/arm-linux-ld: skipping incompatible /usr/lib//libatk-1.0.so when searching for -latk-1.0
/usr/local/codetyphon/fpc/fpc64/bin/x86_64-linux/arm-linux-ld: skipping incompatible /usr/lib//libc.so when searching for -lc
project1.ppr(20,1) Error: Error while linking


thanks

Please Log in or Create an account to join the conversation.

  • Sternas Stefanos
  • Sternas Stefanos's Avatar
  • Away
  • Moderator
  • Moderator
  • Ex Pilot, M.Sc, Ph.D
More
4 months 2 days ago - 4 months 2 days ago #11215 by Sternas Stefanos
Sternas Stefanos replied the topic: CT 6.3 on openSUSE, cross compiling Raspberry3 error
Thanks Sir
give us time,
I will add this task to our LAB team tomorrow, OK

CodeTyphon Architect and Programmer
Last Edit: 4 months 2 days ago by Sternas Stefanos.

Please Log in or Create an account to join the conversation.